Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: PCI Simple Communication Controller, or missing / corrupt file?  (Read 1680 times)

0 Members and 1 Guest are viewing this topic.

Swisstank

  • Guest
Hi,

First, I want to say that I did indeed try to research my problems and symptoms on various FAQ's and forums, but every time some of the symptoms are a bit different. I am familiar with some basic troubleshooting on my computers, but I am by no means knowledgeable enough to figure this out by myself. Everything I know I learned by listening to others, or trying things out by myself. My understanding is basic. I hope my questions do not sound stupid to you, but I am at wits end. I'm writing this from my older Toshiba Satellite Laptop (Win XP). I can bring the 'patient' in to a computer specialist after the weekend, but I would really like to try to figure this out and learn while I am at it.

My PC has been a lot of strange things in succession over the last two days. At this point the only thing that works is BIOS. My USB keyboard does not work in any of the 'black' screens. The keyboard does work fine on the laptop, however, so I know it is not faulty. This computer has from the beginning had a problem with Ps2 keyboards, so all I ever used was the USB. (It beeped at me and wouldn't start up if it had a Ps2 keyboard plugged in.)

I didn't get an error message, so to speak, when it first started doing this. Now, if I start the computer it will start booting up normally, and cycle through some checks, but ends up at a screen that asks to:

'Please select the Operating System to start:
Microsoft Windows XP Home Edition
Microsoft Windows XP Setup'

with the Microsoft Windows XP Setup option highlighted, and a three second timer counting down.
But now, with  the keyboard unusable, I end up at a message:

'Windows could not start because the following file is missing or corrupt: <Windows root>\system 32\hal.dll '

Also, the F8 Function does not seem to work. I can get into the boot menu with F12, but again, I cannot move the selector with the keyboard when I get there. Bios works, but I do not know enough to play with it.

My PC : Antec 450W, Seagate Barracuda 7200.9 300 Gbyte SATA HD, K8 Triton nForce 4SLI, AMD Athlon 64 3700+, EVGA Graphics Acc. GeForce 6600GT, Pioneer DVR-111, 2x OCZ Pc3200 512MB Dual CH.

The computer was bought secondhand, and I wiped everything off it, partitioned the drive, and reinstalled Windows XP about a year ago. It has been working fine. I needed an additional computer to store the large amount of pics my wife has taken. Other than that, all it was used for was the usual things like email, msgr, facebook, etc. All the pics, vids and music are in the large partition, and the OS is on the smaller part. IF i cannot fix the problem I'm having, I might have to wipe the partition and start from scratch...which would be no problem as long as the media files are not affected. But that is plan B.

This is a short summary of what happened just before the PC started acting up. Maybe it helps.

Yesterday, after about two months of not using the PC, I started it and ran Microsoft Updates, and renewed the Trend Micro Internet Security on it. I also connected it to an VDSL router for the first time (it has always been using an Sierra Wireless Aircard to access the web before), and connected to the internet without problems. I also rebooted a couple times for the updates to take effect, all without trouble. So far so good.

It has been a bit sluggish at start-up, so upon counsel from an acquaintance, I used 'Run - ms config' to disable the extensive list of programs that fired up upon start-up, and then sat on the tray. He had said that that could be done without harming the computer, as all those programs and services can be started manually when needed. However, once I did that, it prompted me to restart the computer because I used the ms config to change the way windows started. When I did that, it booted up alright still, but a window popped up saying that  windows has started in a diagnostic mode, and that I had to restart it after I checked the 'normal start-up' box. When it rebooted this time, things were a bit different. The start up was EXTREMELY slow, meaning it would cycle through the regular boot system checks and stuff, and windows started up fine, but once I got to the log in page, and clicked on my account, my desktop background would show up immediately, but no icons would show up. Only after a few minutes (literally) did they pop up, and the tray started showing some icons too, including Trend Micro. Also, the green 'Start' button was no longer green, but gray and boxy, and in the style of earlier Windows OS. However, albeit slow, all functions worked. I could no longer go online, as there was no connectivity on my LAN, when I tried to repair, it said it couldn't acquire the IP.  I had also uninstalled a 'Venturi' program that was installed when I was still using the aircard, using the Add or Remove Programs feature in Control Panel, just before this started happening. As it was uninstalling, it went to a 'Command-Prompt' type screen, and froze there. I had to reboot. It may or may not be relevant.

Now, not really knowing what the problem was, I thought I would use System Recovery to roll back to just before I uninstalled the Venturi program. It rebooted and came back the same, sluggish way. I tried to roll back more, to just after I updated and installed the Trend Micro Internet Security. After it rebooted it told me that the system recovery was unsuccessful. When I went back to System Recovery, all the recovery points were gone. 

I opened my device manager, and saw that the PCI Simple Communications Controller had a yellow question mark on it. I opened its properties and it said that the driver was missing. I inserted a utilities disk, and let it search for the driver, but it said that it couldn't find one.  I inserted a Windows XP disc, and wanted to see if there was a repair console on it. There wasn't. I tried to reboot, and this is where I am now.

I realize that some of you reading this will think that I'm a hopeless imbecile, and that I should have found help long before it got this far. You could be right, but honestly, I can't afford to run to a specialist and spend a couple hundred bucks every time some little thing goes wrong. But I may be in over my head this time. Remember, I'm still trying to learn.  :) Also, I apologize for the random and rambling way this was written. I'm trying to remember the sequence of things as they happened. Any help would be appreciated. Thank you very much.
« Last Edit: April 03, 2010, 05:02:00 AM by Swisstank »