Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: Screwed Up Permissions and Security Settings  (Read 1819 times)

0 Members and 1 Guest are viewing this topic.

Gamer137

    Topic Starter


    Rookie

    Screwed Up Permissions and Security Settings
    « on: November 07, 2010, 08:20:10 PM »
    Hello. I have been using a new laptop with Windows 7 Home Premium 64-Bit.

    TOSHIBA
    Satellite L500
    Pentium Dual-Core CPU T4400
    Fully Up-To-Date

    The laptop has been in use for about five months now and almost entirely has only had one profile. On three or so occasions, I would turn on the Guest account for others users to borrow and gave it stand account permissions. I began setting up a third account also intended for temporary users. While setting up the account with shortcuts, default programs, etc, I tried to access my personal files using this profile to test if others could edit them. After getting the UAC notice and signing in with my password, I could access my personal files using the second account. I then rebooted the system to see if the password would be needed again in the future, but I was able to access my personal files again on the new count without any password needed.

    Now I am unfamiliar with how permissions, security, workgroups, and similar systems work on Windows 7, but I attempted to remedy it myself and ended up screwing it up. Pretending my name is Bob, I opened the properties of C:/Users/Bob and made changes in the security tab. About four different categories were available, but they were not profiles. My memory is fuzzy, but I checked Allow to all permissions to groups I think were called Admins, System, and something else. Another category called something like Workgroup I said Deny to all. A warning popped up saying if a profile belongs to multiple groups, the profile is treated under the group most restricted. I accepted and started having issues.

    My start menu shortcuts had there icons replaced with white paper, my desktop shortcut vanished besides recycling bin, i was unable to access my own personal profile in my own admin account, etc. After trying other similar remedies to try and fix it, I eventually just used system restore to go back to about five days ago; long before i tried adding a new profile or changing any permission settings. While my personal data and programs appear safe and the second account was removed from the sign in screen, I still have issues. I have to jump though hoops to access folders, and I don't appear to have the ability to make changes to the computer. My wallpaper turned into a white screen and I can now change it back although my original wallpapers are still in my files. I can not turn off notifications in the action center. My iTunes program thinks its opening up for the first time every time I open it. Firefox has an issue and can not open up due to being unable to write a certain file or something. Many other similar issues exist. Simply put, my files are safe but myself and my programs are heavily restricted.

    I can provide any other information to help. Thanks for reading.