Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: Printing Using Generic Text Printer Driver  (Read 4486 times)

0 Members and 1 Guest are viewing this topic.

savigent

    Topic Starter


    Newbie

    • Experience: Expert
    • OS: Windows 7
    Printing Using Generic Text Printer Driver
    « on: June 15, 2015, 12:49:59 PM »
    I have a Windows 3.11 system where I'm using the Generic Text Print Driver (TTY.DRV) to print data. I'm capturing the data on another computer via COM port (using a parallel to serial converter). Using Notepad, I try printing Hello World and capturing the text on another computer. The text that comes through is gibberish (Hahhk skrh`).

    I am doing this successfully on other machines. Is there something within Windows 3.11 or within its parallel port that needs to be set up differently (if possible)?

    DaveLembke



      Sage
    • Inventor of the Magna-Broom 3000 =)
    • Thanked: 610
    • Certifications: List
    • Computer: Specs
    • Experience: Expert
    • OS: Windows 7
    Re: Printing Using Generic Text Printer Driver
    « Reply #1 on: June 15, 2015, 01:11:51 PM »
    Sounds like you have wrong baud rate or parity bit issue. I'd double check your serial communication settings to make sure they match between the parallel to serial converter and the computer thats communicating to it via serial.

    Other far less common would be if you were using mouse or other device on Com1 and Serial Com on Com3 and they share same interrupt and so moving the mouse would mess up the data communications, as well as COM 2 and Com 4 in use at same time that also use same interrupt.

    Your close to getting it to work because the placeholders for each character match up for

    Hahhk = 5 characters    and     skrh`= 5 characters
    Hello =  5 characters     and     World = 5 characters

    Also parallel is slower than serial and so I would go with the slowest baud rate for the converter if not default of 9600 baud and set the computer to match that and see if slowing the baud fixes the issue.