Computer Hope

Microsoft => Microsoft Windows => Windows Vista and 7 => Topic started by: Mayuukosan on August 12, 2013, 07:01:37 PM

Title: External Drive Formats itself when connected to work computer?
Post by: Mayuukosan on August 12, 2013, 07:01:37 PM
Another odd issue for you guys.

This involves two computers, my home computer which is :
OS                  Windows 7 Ultimate 64-bit
Video card      GeForce GTX 660
Processor        AMD A10 5800K processor
Ram                 8GB
Motherboard   ASUS F2 A85-M PRO
Power supply  Raidmax RX-730SS

And my work computer, which is:

iMac OSX, pretty sure it's Mountain Lion BUT:

It has, on VMWare, Windows XP Professional, which is where the error is occuring.

My external is a 1TB Western Digital My Book drive, I also tested a 500GB drive with same results.

The issue and exact happenings:

I placed some files on my drive from SolidWorks (a program) which I had created at home.

I brought the drive to work and plugged it into the iMac, intending to copy the files from the external to VMWare (XP).

When I attached the drive, it asked if I wanted to connect to the Mac or to XP (Forgot the exact message) but I chose XP.

It stated "Unknown device" on the taskbar, so I went to the Device manager, sure enough, it said "Unrecognized device". I downloaded the WD Drivers from their site and installed them.

Now the Device Manager recognized it as "Mass Storage Device" but it didn't appear in the My Computer spot, in the Disc management it showed the disc as "Uninitialized" and was not assigned a drive letter. On right click, all the options except "Help" were greyed out.

So I brought the drive back home, and it showed up on my home computer as "Uninitialized". I initialized the disc, had to "Create New Simple Volume" and recopied the files.

Next day, brought it back to work, and same thing happened.

I put some files on it from work, and brought the external home, and my home computer can read the files I placed on it at work.

This is fully reproducible, for the last 4 days, with two external drives.

So, somehow, if I place files on an external on my home computer, then attach the drive to my work computer, it will basically wipe the drive.

Other information, in no particular order:

Attaching an external to my work computer if it had previously been attached to my home computer erases it. This only seems to occur from externals from my home computer to my work computer.

Attempts to recover the files (Used Recurva and Puran File Recovery, no files found) all fail. No files are found to recover, even if I never "Initialize" the disc or "Create New Simple Volume".

Files that are placed to the drive from the work computer are read fine on my home computer, but if I bring those same files back to work, it fails if I had plugged the drive into my home computer.

The work computer DOES recognize flash drives without wiping them, which is how I have been moving the files now.

The work computer DOES recognize files on my externals from other work computers (Also iMacs).

I do not need to reinstall the WD drivers each day, it now recognizes the drive immediately but never assigns it a letter, it treats it as a RAW drive and shows it as RAW format

I did try other WD drivers, with same results (if the drivers worked).

The drive also appears empty if I choose to attach to Mac side instead of VMWare. It doesn't appear in Finder, I am not too experienced in Macs. It did not appear in Disc Utilties but it did appear in the System Profile as unrecognized. I expect this, as it is a NTFS drive.

As stated above, I used both a 1TB and 500MB drive, both formatted to NTFS, which, if I remember right, Macs can read but not write to. This didn't bother me, as I just wanted to copy files from the external to XP on VMWare.

The external IS recognized on my work computer IF I haven't plugged it into my home computer first, so once I plug it into my work computer, the drive is wiped. What I mean is, if the drive is plugged into ANY OTHER COMPUTER, IT IS READ FINE. It is only if it was plugged into my home computer THEN work computer that it wipes.

If I plug it into other computers at work, then my work computer, it functions fine. If I plug it into my home computer, then into ANY other computer at work (tested on 5 other iMacs with Windows XP in VMWare) IT IS FINE. The error ONLY occurs when going from Home > MY work computer. It is driving me insane.

Edited to add
I tried several USB ports on both my home computer and the iMac as well as a third enclosure, and different cords. Both externals are the kind that also plug into a wall socket. I tried alternate power cords.

I tied plugging into the USB ports on the keyboard of the iMac as well as directly into the ports on the back to the same result.

It seems odd, it is just files/drives from my home computer to my work computer that is the issue. I tested the externals using the WD hard drive scanner (Forget the exact name, was one of the first things I did) and it came back with No errors, and No failures.

Ran virus scans on both computers, no issues.

Does anyone have a guess about what it could be? Is it my work computer? My home computer? My externals? VMWare? Where should I go from here? What should I do?

Is this post even in the correct spot? As it involves 7, XP, OSX, and an external, I didn't even know where to start. Will gladly post to more appropriate forum if you ask.

I understand this all sounds confusing, I tried to make it as clear as I could. Tried to research the issue on my own, but couldn't find anything related.

Thanks for any help!

Title: Re: External Drive Formats itself when connected to work computer?
Post by: jason2074 on August 13, 2013, 11:50:02 PM
Do you mean that your work computer VMWare XP automatically erases the files or it posts an error message first? Most drivers are generic on usb mass storage AFAIK. Have you tried formatting the drive to FAT32/NTFS before taking it back to the work computer?
Title: Re: External Drive Formats itself when connected to work computer?
Post by: Mayuukosan on August 14, 2013, 04:44:22 AM
When the drive is plugged into the work computer, the first time it said it didn't recognize it (I needed to install the drivers). I installed the Western Digital drivers for XP from WDs website, and then it recognized the drive, but it showed up as RAW and was not assigned a letter.

The second and each time since then, it states "Mass Storage Device" yet the drive doesn't appear in explorer, in Device manager it states Mass Storage Device, but in Disc Management it states the drive is "RAW" and Uninitialized. It is also not assigned a letter.

If I choose to "initialize" the drive, it appears as "Unallocated".

Basically, the XP acts as if I have plugged in a fresh, never used drive.

There is no error message when I plug in the drive to XP. It recognizes the drive, as far as I can tell, what it seems to be doing is formatting the drive when I plug it in. But I can't understand why it only does it for drives from my computer (Or why it does it at all).

If I recall correctly, a 1TB drive Can't be formatted to FAT32? I have it currently formatted to NTFS.

Other NTFS drives DO work in the XP computer, IF they haven't been plugged into my home computer first.

Flash drives DO work from my home computer to my work computer.


Title: Re: External Drive Formats itself when connected to work computer?
Post by: jason2074 on August 14, 2013, 11:02:56 PM
The VMware community such as this thread ( might help you. A worth trial and error procedure is to format the NTFS WD drive back to FAT32. I've read there is a software for WD drives that are 1 TB more or less in capacity could convert them for certain purposes. Make sure to backup your documents before proceeding with this method.

How to Format a WD external drive? (http://",219,290/session/L3RpbWUvMTM3NjU0MDc4Ni9zaWQvRlV4dHBPeGw%3D")
Title: Re: External Drive Formats itself when connected to work computer?
Post by: Mayuukosan on August 18, 2013, 06:49:23 AM
Thank you Jason2074, I will try looking around the VMWare forums before posting there, maybe they do have a solution.

Just as an aside, formatting to FAT32 didn't help either. The drive is still showing up as "Uninitilized" and "Unallocated" when being plugged into my work computer.

At this point, I am simply using a flash drive instead, so this issue has become moot, just one of those quirks I will need to work around.

Not quite solved, but thanks for all the help!  :)
Title: Re: External Drive Formats itself when connected to work computer?
Post by: jason2074 on August 18, 2013, 08:06:08 AM
See if this would help. For VMWare Fusion
Title: Re: External Drive Formats itself when connected to work computer?
Post by: Geek-9pm on August 18, 2013, 10:28:14 AM
First, thank you very much for you hard work and sharing it with the forum. This information is very valuable. It is important to know not just what does work, but what does not work.
This post is not a solution. Instead this is a workaround. Maybe two.
A. Use flash drives. The OP has already verified that works.
At one retailer.,  for $24.99 you can get a 32 GB. Five would be about $125 to give you 160GB, It is not likely you need to transfer very large files.
B. Get another computer. Find one that can work between the others . A laptop or very small computer you can cart between home and work. Do file transfer using the Ethernet, not the USB. (That sis, the USB external  stays with the laptop.)

The second idea is on the speculation that the issue is using USB on different computers. The problem should disappear if only Ethernet is used for file transfer. You may find some case where you do USB in but Ethernet out. Or the other way.
Just a suggestion.  :)
Title: Re: External Drive Formats itself when connected to work computer?
Post by: skeen on August 24, 2013, 01:45:47 PM
The Western Digital My Book drive has a built in encryption option. Great for security, not good for data recovery.  I wonder if that has anything to do with it.  You mentioned file recovery software didn't recover anything. Also the fact the drive needed drivers at work seems unusual.