Computer Hope

Other => Computer Hope groups => [email protected] (Team: 67290) => Topic started by: DaveLembke on November 23, 2013, 07:54:21 PM

Title: Strangeness after messing around with folding service..waiting, waiting, waiting
Post by: DaveLembke on November 23, 2013, 07:54:21 PM
So I decided that I wanted folding to crunch heavily on my wifes idling computer during periods of the day when she isnt using it which is between say 2am and 2pm. I have the folding @ home service set to manual startup. I then added a shortcut to a startup in scheduled tasks to launch [email protected] and that worked fine. And at 2pm with no better way to shutdown the [email protected] to shut off for the next 12 hours, I use a Task Kill process in another scheduled task that stops it from running.

This worked ok for about 4 days and then I think I broke [email protected], but it doesnt error out. Instead it launches now at 2am and doing so Firefox launches and it then comes up to the Web GUI showing the [email protected] activity and it says that its waiting and shows a count down of say 2 minutes. When the counter gets to 0, it then shows a count down of say 5 minutes and then when the count down gets to 0, it then keeps saying waiting with a different wait period. During this time the CPU is idle at like 5% in use. [email protected] no longer crunches proteins.

Also, if there is a more graceful way of stopping [email protected] at 2pm than a taskkill /T please let me know. I tried targeting the single service that is running and killing it caused it to end and then restart about 30 sec later. So I had to go with the Taskkill /T method to kill it.

*Note I can supply the actual kill command if needed to show which service name is targeted but from memory I cant remember the exact name of it, but can provide that info when I get home from work to copy/paste it here.

So I am wondering if I broke [email protected] by killing it in the middle of crunching through the Taskkill /T which kills [email protected] and all related subprocesses of it. I looked all over for a way to make it only run on a schedule and the only thing I can come up with is to start the service and kill the service to control when its run. In doing so its no longer happy and I figured I'd ask here to see if others who have run [email protected] have seen this before and the fix?

I was going to uninstall it and reinstall the Windows [email protected] client again and then configure for the group and set it crunching, but maybe this can be cleared up by wiping out a corrupt file or something that is related to the [email protected] startup vs a reinstall of the client. Maybe it was writing its results at the same time that the service was killed etc, which is a possibility with the write to disk I set to every 5 minutes so that data processed was check pointed more frequently to minimize wasted crunch time when the service was killed to where the maximum crunch time loss was less than 5 minutes, and then the following day at 2am it picks up where it left off.
Title: Re: Strangeness after messing around with folding service..waiting, waiting, waiting
Post by: Calum on November 24, 2013, 03:22:56 AM
If I were you I would uninstall [email protected] completely and make sure any startup items and services are gone, then reinstall the CLI client as a service, rather than the GPU client.  You can then use "net stop [fahservice]" and "net start [fahservice]" (can't recall the service names off the top of my head) to stop and resume folding.
Make sure when you install the CLI client to go through the process nice and slow, don't accidentally hit enter more than once and skip a step you needed like your username or team, and then have to run "fah.exe -configonly" to do it all again...don't ask me how I know that's annoying.
That would be a more elegant solution than killing the process, not sure how [email protected] responds to that nowadays but from the issues you've run into I'm assuming it responds about as well as it used to :P

Let me know if you run into any issues, been a while since I've done any [email protected] so the guide on the folding site may have changed, along with the client, but if you run into any problems I'll fire it up myself and see where I went wrong heh.
Title: Re: Strangeness after messing around with folding service..waiting, waiting, waiting
Post by: DaveLembke on November 24, 2013, 04:09:02 AM
Thanks for info... will give that a try