Computer Hope

Microsoft => Microsoft Windows => Windows Vista and 7 => Topic started by: mjacqu6 on December 06, 2013, 01:47:42 AM

Title: Cant boot after windows update
Post by: mjacqu6 on December 06, 2013, 01:47:42 AM
Earlier this evening, windows surprised me by restarting to preform a windows update. I went to go do something else for half hour or so, and when I came back I saw the startup repair was running.

On startup right after the windows logo come up, I get blue screen with error PROCESS1_INITIALIZATION_FAILED 0x0000006B.

Same thing on safe mode and "last successful boot config."

All of my restore points failed, and startup repair fails.

Checkdisk says no problems found, and SFC finds corrupt files and repairs them every time I run it, but the blue screen still comes up.

I tried using the widows 7 recovery disk but that failed too.

I have done a LOT of reading on the subject and based on the evidence, believe this is due to corruption of ntdll.dll in system32.

There was a forum thread where it was suggested I replace this file from the same version of windows followed by many replies from users who were able to successfully fix their issue this way. When I try to copy the clean version of ntdll.dll into my system using the recovery console, however, I the the error

The requested operation cannot be performed on a file with a user-mapped section open.

I suspect this means some process is using the file or something like that. Somehow, other people were able to get it to work.

Can anyone PLEASE help me replace this file (or suggest some other creative fix for this issue).

I would really really like to avoid re-installing

Title: Re: Cant boot after windows update
Post by: mjacqu6 on December 06, 2013, 03:40:49 AM
Update: This is not a hardware issue. I was able to boot the computer using an ubuntu usb stick, mount the windows drives and transfer all of my important files off. Unfortunately replacing that .dll file did not fix the issue.
Title: Re: Cant boot after windows update
Post by: patio on December 06, 2013, 06:39:15 AM
Try running the Startup Repair's possible you lost power or something when it ran before...
If a laptop have it on A/C for this.