Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: At boot - AUTONTFS program not found  (Read 21063 times)

0 Members and 1 Guest are viewing this topic.

tgp1994

    Topic Starter


    Beginner

  • Think happy thoughts and have a nice day.
  • Thanked: 2
    • Yes
  • Experience: Experienced
  • OS: Other
At boot - AUTONTFS program not found
« on: June 05, 2010, 01:18:27 PM »
Here's a little problem and solution I experienced today, that I would like to spread around the internet so other people with this issue can easily fix it.

First, a little background:

The reason you're seeing this error is because window is trying to find an executable, which it can't. Windows will, by default, look in the C:\WINDOWS\system32\ folder for executables. Well, why is it looking for this specific program? You may be asking yourself. The reason is, you may have asked Diskeeper to do a Boot-Time De-fragmentation.

Ahh! Is it a virus? Is it bad!?

No, this particular program, along with Diskeeper, is perfectly safe. However, viruses may hijack it. If know you did not specifically ask diskeeper to do a boot time de-fragmentation, then please look in the appropriate virus forum section for cleaning your computer.

Ok, I want to do a boot time defragmentation. How can I proceed?

Open up your C: drive, then navigate to Program Files -> Diskeeper Corporation -> Diskeeper. Right click on the file named AutoNTFS.exe, and select copy. Now navigate back to your C drive, then browse as follows: WINDOWS -> system32. Once in the system32 folder, right click in an empty area and click paste.
You may now reboot your computer, and the boot time defragmentation will begin.

I did not ask diskeeper to do this for me, or I do not have Diskeeper.

This procedure will require that you are fairly comfortable with the Windows registry. If you are not, please ask someone who is to do this for you.

To open the Windows Registry Editor, go to Start -> Run, and type in regedit. Click Ok, then in the new window, browse the Folder structure as follows: HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Session Manager. At this point, you can probably tell that we are in a very important part of the computer. It's best to back up the registry now. In the folder browser on your left, right click the folder you just clicked on, Session Manager. Click Export, then save it to My Documents as regbackup. Now back in the Registry Editor, double click on the value BootExecute. In the window that just came up, delete everything in it, and copy+paste in the following:
Quote
autocheck autochk *
Click ok, then close out of the registry editor. After rebooting your computer, the error message will no longer come up!

Help! I did something wrong while editing my registry, and now something else is acting up.

Simply double click on the file we exported earlier, in your My Documents folder. Click ok. If the new problem does not go away, chances are something unrelated to this has gone wrong. It is best if you ask your question in the appropriate section.

I hope this helps everyone! Please tell me if I missed something.

Credits go to this topic for the procedure.

kpac

  • Web moderator


  • Hacker

  • kpac®
  • Thanked: 184
    • Yes
    • Yes
    • Yes
  • Certifications: List
  • Computer: Specs
  • Experience: Expert
  • OS: Windows 7
Re: At boot - AUTONTFS program not found
« Reply #1 on: June 05, 2010, 01:29:57 PM »
Thanks for sharing. :)

tgp1994

    Topic Starter


    Beginner

  • Think happy thoughts and have a nice day.
  • Thanked: 2
    • Yes
  • Experience: Experienced
  • OS: Other
Re: At boot - AUTONTFS program not found
« Reply #2 on: June 05, 2010, 01:48:36 PM »
Thanks for sharing. :)

No problem :D Makes a gesture towards the thanks button