Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: IE 7 saying "Cryptographic service not working"  (Read 6532 times)

0 Members and 1 Guest are viewing this topic.

jayajean

    Topic Starter


    Rookie

    IE 7 saying "Cryptographic service not working"
    « on: May 13, 2008, 01:34:54 AM »
    I use Windows XP Service pack 2 and IE 7 and am having a problem viewing webpages that require logins or passwords, ie., bank websites, email, etc.  I downloaded firefox and everything works fine. 
    I tried to reinstall IE 7 and even downloaded IE 8 Beta but when I try to run them I get a message saying
    "Setup could not verify the integrity of these files.  Make sure the cryptographic service is running on this computer.

    Could you tell me what might be wrong with IE?
    This has happened before, but within a couple of days, the problem seemed to resolve itself???
    Thanks!

    Broni


      Mastermind
    • Kraków my love :)
    • Thanked: 613
      • Computer Help Forum
    • Computer: Specs
    • Experience: Experienced
    • OS: Windows 8
    Re: IE 7 saying "Cryptographic service not working"
    « Reply #1 on: May 13, 2008, 06:42:59 PM »
    Go Start>Run, type in:
    services.msc
    Click OK.
    Find Cryptographic Services in the list, and see if it's listed as Started, and its startup type is set to Automatic.

    kernel



      Rookie

      Re: IE 7 saying "Cryptographic service not working"
      « Reply #2 on: May 13, 2008, 09:17:34 PM »
      Have same problem but when I tried to correct got "error message 193"  HELP!-please

      Broni


        Mastermind
      • Kraków my love :)
      • Thanked: 613
        • Computer Help Forum
      • Computer: Specs
      • Experience: Experienced
      • OS: Windows 8
      Re: IE 7 saying "Cryptographic service not working"
      « Reply #3 on: May 13, 2008, 09:29:39 PM »
      kernel
      Please, start your own topic.

      jayajean

        Topic Starter


        Rookie

        Re: IE 7 saying "Cryptographic service not working"
        « Reply #4 on: May 14, 2008, 02:15:02 AM »
        I checked Cryptographic services under "services msc" and yes it is started and runs automatically.

        Broni


          Mastermind
        • Kraków my love :)
        • Thanked: 613
          • Computer Help Forum
        • Computer: Specs
        • Experience: Experienced
        • OS: Windows 8
        Re: IE 7 saying "Cryptographic service not working"
        « Reply #5 on: May 14, 2008, 06:17:01 PM »
            * If the Cryptographic Services service was already running, stop the service by clicking the Stop button. Using Windows Explorer, locate the folder C:\Windows\System32\catroot2 and rename it to something like xcatroot. Now restart Cryptographic Services by clicking the Start button, and try IE again.
            * If same error still occurs, stop the Cryptographic Services service again. Open a command prompt window (click Start, Run, type cmd and hit Enter) and then type the following commands:

        regsvr32 softpub.dll
        regsvr32 wintrust.dll
        regsvr32 initpki.dll
        regsvr32 dssenh.dll
        regsvr32 rsaenh.dll
        regsvr32 gpkcsp.dll
        regsvr32 sccbase.dll
        regsvr32 slbcsp.dll
        regsvr32 cryptdlg.dll

        Restart Cryptographic Services by clicking the Start button again. Try IE.

        jayajean

          Topic Starter


          Rookie

          Re: IE 7 saying "Cryptographic service not working"
          « Reply #6 on: May 15, 2008, 01:35:10 AM »
          Renaming the folder to xcatroot did not work.  I enter the commands but when I when to restart the cryptographic service, I got an "Internet explorer script error"
          Line: 1
          Character: 1
          Error: Unknown
          Code: 0
          URL: res://C:\WINDOWS\System32\mmcndmgr.dll/views.htm
          Do you want to continue running scripts on this page?
          I entered yes & no and it still would not start.


          cryhelp



            Hopeful
          • Only the educated are free=Epictetus
            "Training is everything. The peach was once a bitter almond; cauliflower is nothing but cabbage with a college education"  Mark Twain

            Broni


              Mastermind
            • Kraków my love :)
            • Thanked: 613
              • Computer Help Forum
            • Computer: Specs
            • Experience: Experienced
            • OS: Windows 8
            Re: IE 7 saying "Cryptographic service not working"
            « Reply #8 on: May 15, 2008, 04:23:08 PM »
            Go Start>All Programs>Accessories>System Tools, and click on IE (no add-ons).
            Same thing happens?

            jayajean

              Topic Starter


              Rookie

              Re: IE 7 saying "Cryptographic service not working"
              « Reply #9 on: May 16, 2008, 01:32:59 AM »
              Yes, lol...that worked..why?  So, do I have to restart the cryptographic service because it would not work yesterday after I did what you told me....
              thanks!!

              Broni


                Mastermind
              • Kraków my love :)
              • Thanked: 613
                • Computer Help Forum
              • Computer: Specs
              • Experience: Experienced
              • OS: Windows 8
              Re: IE 7 saying "Cryptographic service not working"
              « Reply #10 on: May 16, 2008, 05:36:32 PM »
              Some IE add-on is messing up things. To find out, which one....
              Open IE normally, go Tools>Internet Options>Advanced tab, and click "Reset" button.
              This will disable all add-ons.
              Restart computer. See, if you can access sites in question.
              If you do, start enabling add-ons, one-by-one, restarting IE each time, and checking troubled sites access.
              Do so, until you'll find the culprit.