Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: Windows 98; Need Help  (Read 15853 times)

0 Members and 1 Guest are viewing this topic.

bil_drk

    Topic Starter


    Beginner

    Thanked: 1
    Windows 98; Need Help
    « on: June 27, 2009, 06:07:54 PM »
    I have an old IBM PC with windows 98 1st. Recently, my CD drive burned out of it, and i had a spare so i plugged it in and it lit up, opens and closes so i assume it works. well, after tinkering i found out i was missing the file APPS.INF, and i obtained the file and went to look for the INF folder in the windows folder, but couldn't find it. I did make sure that all hidden folders were visible. So, i created a blank folder and put apps.inf in it, thinking it would work. well, it didn't. so now, i don't know what to do. I tried to run the search for new hardware wizard, but it couldn't find it either. I really need my computer back ASAP, so any help would be appreciated. Thanks in advance to those who help me.

    hot dog

    • Guest
    Re: Windows 98; Need Help
    « Reply #1 on: June 27, 2009, 06:12:48 PM »
    Boot into DOS mode, type: attrib -h -s -r c:\windows\inf          press enter and restart the computer in normal mode and see if the INF folder has appeared...next put the file into the INF folder

    you could also put the installation CD in your CD drive....Click START, click RUN to open a RUN command..

    type:  sfc /scannow  click OK, and see if the System File Checker will reinstall the file for you

    JJ 3000



      Egghead
    • Thanked: 237
    • Experience: Familiar
    • OS: Linux variant
    Re: Windows 98; Need Help
    « Reply #2 on: June 27, 2009, 06:20:31 PM »
    Are you sure the jumper is is the correct position?
    Is the IDE ribbon connected to both the drive and the motherboard?
    Have you tried a different IDE ribbon? The old drive might not have burned out after all.
    Save a Life!
    Adopt a homeless pet.
    http://www.petfinder.com/

    bil_drk

      Topic Starter


      Beginner

      Thanked: 1
      Re: Windows 98; Need Help
      « Reply #3 on: June 27, 2009, 09:44:58 PM »
      would any of you two happen to have anymore suggestions? I tried them both and they didn't work. I double checked and made sure the drive was connected to the motherboard and the cd drive. i also typed in the command exactly the same. the computer told me it was a bad command. i also ran the system file checker, and it said my files were okay. i also ran registry checker, it also said my registry was okay. whenever i open up setup menu, i check my IDE devices and it says IDE: CD-ROM PORT 0. I'm assuming this means it has found it, but unsure why windows cannot recognize it.

      Quantos



        Guru
      • Keep Calm - Press Play
      • Thanked: 168
        • Yes
        • Yes
      • Computer: Specs
      • Experience: Guru
      • OS: Linux variant
      Re: Windows 98; Need Help
      « Reply #4 on: June 27, 2009, 10:06:15 PM »
      Can you locate the INF folder through the command line?
      Do You Think When You Act Or Just Act Like You’re Thinking?

      hot dog

      • Guest
      Re: Windows 98; Need Help
      « Reply #5 on: June 27, 2009, 10:24:24 PM »
      Can you locate the INF folder through the command line?

      this is a good idea..

      boot into DOS mode type:  dir c:\windows\inf           hit enter

      If the INF folder is there, the folders contents should be displayed when pressing enter

      Once you've verified that it's there, boot back into the Windows GUI and copy the apps.inf file to the root of the C drive.....C:\

      then boot back into DOS mode and type:

      copy c:\inf c:\windows\inf

      press enter and it should copy the file to the INF folder


      Does Device Manager reveal any errors?




      « Last Edit: June 28, 2009, 01:23:09 AM by blockHEAD »

      bil_drk

        Topic Starter


        Beginner

        Thanked: 1
        Re: Windows 98; Need Help
        « Reply #6 on: June 28, 2009, 10:56:22 AM »
        device manager has been acting a tad weird, but not as weird as my add new hardware wizard. when i click on the 'manually install hardware' tab, it shows a list of accelerators, CD-Rom controlers, etc. but when i click on one of those tabs, several manufacturers should appear- its just a white screen. this is why i thought i was missing the INF folder, but now i'm unsure.

        Quantos



          Guru
        • Keep Calm - Press Play
        • Thanked: 168
          • Yes
          • Yes
        • Computer: Specs
        • Experience: Guru
        • OS: Linux variant
        Re: Windows 98; Need Help
        « Reply #7 on: June 28, 2009, 11:32:56 AM »
        Can you locate the INF folder through the command line?
        Do You Think When You Act Or Just Act Like You’re Thinking?

        bil_drk

          Topic Starter


          Beginner

          Thanked: 1
          Re: Windows 98; Need Help
          « Reply #8 on: June 28, 2009, 12:07:58 PM »
          no; i typed in the code blockHEAD gave me i had too to make it appear; it gave me my drive information, and it said the file could not be found. where do i go from here?

          Quantos



            Guru
          • Keep Calm - Press Play
          • Thanked: 168
            • Yes
            • Yes
          • Computer: Specs
          • Experience: Guru
          • OS: Linux variant
          Re: Windows 98; Need Help
          « Reply #9 on: June 28, 2009, 12:10:59 PM »
          I guess I could have been more specific. :)

          I mean going into the command line, going into the Windows directory and determining if you can even just see the INF Folder. 
          Do You Think When You Act Or Just Act Like You’re Thinking?

          bil_drk

            Topic Starter


            Beginner

            Thanked: 1
            Re: Windows 98; Need Help
            « Reply #10 on: June 28, 2009, 01:13:35 PM »
            this means i boot in DOS mode right? what do i type when i get there?

            hot dog

            • Guest
            Re: Windows 98; Need Help
            « Reply #11 on: June 28, 2009, 02:32:01 PM »
            type:  dir c:\windows

            If the INF folder exists, you should see it in the list after pressing ENTER

            bil_drk

              Topic Starter


              Beginner

              Thanked: 1
              Re: Windows 98; Need Help
              « Reply #12 on: June 28, 2009, 02:34:14 PM »
              thank you blockhead. if it is not there, what do i do?

              hot dog

              • Guest
              Re: Windows 98; Need Help
              « Reply #13 on: June 28, 2009, 02:47:56 PM »
              this is not an expert idea, but you could boot back into Windows as you would normally, and create a folder named    inf    inside the WINDOWS folder and then place the apps.inf file in the   inf   folder


              What does it look like in Device Manager?  Are there any yellow exclamation marks or red X's?

              bil_drk

                Topic Starter


                Beginner

                Thanked: 1
                Re: Windows 98; Need Help
                « Reply #14 on: June 28, 2009, 02:57:37 PM »
                i tried to search the directory with the command given; this time the command worked! however, i couldn't find the INF folder even through searching the directory.
                i did try to name a folder INF and placed APPS inside it, but that didn't work. i was told by someone else that naming a folder INF and placing APPS inside it wouldn't work, after i had already tried it. As far as the device manager their are a few red x's, but no yellow lines.