Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: disable the ease of access button  (Read 8138 times)

0 Members and 1 Guest are viewing this topic.

carlrowley1

    Topic Starter


    Hopeful

  • liverpool fc
    disable the ease of access button
    « on: July 05, 2009, 03:30:11 AM »
    Hello
    The download software from softpedia to disable the ease of access button, doe's not support windows vista sp2.

    Unless i have missed it somewhere is there a version now that doe's support this.

    I did not know that this button, can mess with your computer even when locked, until the little lad showed me that you can

    So is there a way you can disable it if you have
    Vista home premium sp2.

    Thanks guys
    windowsXP professional sp3, Ram 512 , 1.30 gigahertz AMD Athlon, Maxtor 4r080L0 hard drive.

    Laptop Toshiba.  L300/L300D series/windows vista home premium/
    2gb ram/32 bit/

    Windows 7 / home premium / 64 bit /3gb system ram /

    Broni


      Mastermind
    • Kraków my love :)
    • Thanked: 614
      • Computer Help Forum
    • Computer: Specs
    • Experience: Experienced
    • OS: Windows 8
    Re: disable the ease of access button
    « Reply #1 on: July 05, 2009, 10:36:56 AM »
    Where do you have this button?

    patio

    • Moderator


    • Genius
    • Maud' Dib
    • Thanked: 1701
      • Yes
    • Experience: Beginner
    • OS: Windows 7
    Re: disable the ease of access button
    « Reply #2 on: July 05, 2009, 10:44:00 AM »
    Start/Control Panel/Ease of Access Center has all the settings...
       
     
    " Anyone who goes to a psychiatrist should have his head examined. "

    carlrowley1

      Topic Starter


      Hopeful

    • liverpool fc
      Re: disable the ease of access button
      « Reply #3 on: July 05, 2009, 02:39:45 PM »
      Start/Control Panel/Ease of Access Center has all the settings...

      hi, patio

      The only settings that i can see for this is this check box here, but i am noy sure what this doe's.



      i did read you have to rename the utilman.exe file in the System32 folder , but in cases this doe's not work

      (windows vista home premium)
      windowsXP professional sp3, Ram 512 , 1.30 gigahertz AMD Athlon, Maxtor 4r080L0 hard drive.

      Laptop Toshiba.  L300/L300D series/windows vista home premium/
      2gb ram/32 bit/

      Windows 7 / home premium / 64 bit /3gb system ram /

      Mulreay

      • Guest
      Re: disable the ease of access button
      « Reply #4 on: July 06, 2009, 07:20:06 AM »
      Unfortunately, we can’t remove the button, but we can make it disabled so nobody can actually use it. Download and unzip the software, and then right-click on the setup file and choose Run as Administrator.

      Choosing to run it as administrator is such an important step that the software will remind you regardless.

      You’ll finally get to the screen where you can click the Disable button to make the button not work anymore. If you wanted to re-enable it, just run the setup again and click the Enable button.

      And now you’ll get this message anytime you click on the Ease of Access button.

      Sorry I'm not very good at adding pics inbetween text so the pics attached are relevant to each paragraph.



      [attachment deleted by admin]

      carlrowley1

        Topic Starter


        Hopeful

      • liverpool fc
        Re: disable the ease of access button
        « Reply #5 on: July 06, 2009, 08:52:37 AM »
        hello

         
        Quote
        Download and unzip the software, and then right-click on the setup file and choose Run as Administrator.

        I have already done this, but when you do finally set it up, it doe's  not support windows vista service pack 2.

        Have you got a link for this software that doe's support this
        windowsXP professional sp3, Ram 512 , 1.30 gigahertz AMD Athlon, Maxtor 4r080L0 hard drive.

        Laptop Toshiba.  L300/L300D series/windows vista home premium/
        2gb ram/32 bit/

        Windows 7 / home premium / 64 bit /3gb system ram /

        Broni


          Mastermind
        • Kraków my love :)
        • Thanked: 614
          • Computer Help Forum
        • Computer: Specs
        • Experience: Experienced
        • OS: Windows 8
        Re: disable the ease of access button
        « Reply #6 on: July 06, 2009, 04:39:53 PM »
        As far as I searched, it seems to be impossible to disable it in SP2.

        carlrowley1

          Topic Starter


          Hopeful

        • liverpool fc
          Re: disable the ease of access button
          « Reply #7 on: July 06, 2009, 05:57:39 PM »
          As far as I searched, it seems to be impossible to disable it in SP2.


          Well Broni, i am surprised, its not a big issue but if i could have disabled it i would have, there is one thing i have not tryed yet and that is

          you have to rename the utilman.exe file in the System32 folder , but in cases this doe's not work


          but i will probably just leave it alone now .  8)
          I did try searching also, but i could not find anything also.
          So thanks for trying anyway
          windowsXP professional sp3, Ram 512 , 1.30 gigahertz AMD Athlon, Maxtor 4r080L0 hard drive.

          Laptop Toshiba.  L300/L300D series/windows vista home premium/
          2gb ram/32 bit/

          Windows 7 / home premium / 64 bit /3gb system ram /

          killerb255



            Adviser
          • Thanked: 35
            • Experience: Expert
            • OS: Windows 7
            Re: disable the ease of access button
            « Reply #8 on: July 08, 2009, 11:17:26 AM »
            I'm surprised there's no Group Policy built-in or custom .admx file to do this...
            Quote from: talontromper
            Part of the problem is most people don't generally deal with computer problems. So for most they think that close enough is good enough.

            Broni


              Mastermind
            • Kraków my love :)
            • Thanked: 614
              • Computer Help Forum
            • Computer: Specs
            • Experience: Experienced
            • OS: Windows 8
            Re: disable the ease of access button
            « Reply #9 on: July 08, 2009, 04:50:50 PM »
            You have 24 hours to find it  ;D

            killerb255



              Adviser
            • Thanked: 35
              • Experience: Expert
              • OS: Windows 7
              Re: disable the ease of access button
              « Reply #10 on: July 08, 2009, 08:03:22 PM »
              How about less? :)

              I didn't find a Group Policy to stop it.  The closest I could find through Group Policy was Software Restrictions.  Restricting the file C:\Windows\System32\utilman.exe stops it from being run while logged in, but not on the logon screen.

              However...

              Changing the permissions on utilman.exe works wonders!

              1) Take ownership of the file first!!!  VERY important!!!  Make sure that you make your user account or a group that your account is a member of the owner!!!

              2) Remove all permissions to the file (yes, that includes Administrators, Users, TrustedInstaller, and SYSTEM).  You'll get a warning saying that nobody can access the file and only the owner can change permissions.  Go ahead and click "Yes." 
              NOTE: If there are minimal permissions that can be assigned without allowing the button to work, I'll find out shortly and edit this post.

              3) Reboot.

              4) Try clicking the Ease of Access button on the logon screen.

              5) ?????

              6) Profit! (aka: nothing happens)

              Now, to mass deploy something like this, you'll probably have to use a batch file containing a for loop, a list of computers in a text file, connect to \\computername\c$\windows\system32, and run a series of icacls commands against utilman.exe that would allow the domain admin to take ownership and nuke all the permissions on each utilman.exe file. 

              EDIT: I've tried only the SYSTEM account with Read permissions, and that restores functionality to the button.  Same with only Users Read and Administrators Read.  So what I said still stands: NUKE 'EM ALL!!!!  You might be able to get away with granting only one individual user account access, though...
              « Last Edit: July 08, 2009, 08:16:37 PM by killerb255 »
              Quote from: talontromper
              Part of the problem is most people don't generally deal with computer problems. So for most they think that close enough is good enough.

              carlrowley1

                Topic Starter


                Hopeful

              • liverpool fc
                Re: disable the ease of access button
                « Reply #11 on: July 09, 2009, 05:45:14 AM »
                1) Take ownership of the file first!!!  VERY important!!!  Make sure that you make your user account or a group that your account is a member of the owner!!!



                hello
                How would i do this, i have a standard aaccount
                windowsXP professional sp3, Ram 512 , 1.30 gigahertz AMD Athlon, Maxtor 4r080L0 hard drive.

                Laptop Toshiba.  L300/L300D series/windows vista home premium/
                2gb ram/32 bit/

                Windows 7 / home premium / 64 bit /3gb system ram /

                Broni


                  Mastermind
                • Kraków my love :)
                • Thanked: 614
                  • Computer Help Forum
                • Computer: Specs
                • Experience: Experienced
                • OS: Windows 8

                carlrowley1

                  Topic Starter


                  Hopeful

                • liverpool fc
                  windowsXP professional sp3, Ram 512 , 1.30 gigahertz AMD Athlon, Maxtor 4r080L0 hard drive.

                  Laptop Toshiba.  L300/L300D series/windows vista home premium/
                  2gb ram/32 bit/

                  Windows 7 / home premium / 64 bit /3gb system ram /