Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: How do I change a Group Policy Editor option from being grayed out?  (Read 6527 times)

0 Members and 1 Guest are viewing this topic.

Scotty81

    Topic Starter


    Starter

    • Experience: Beginner
    • OS: Unknown
    I am running a Windows XP SP2 machine.

    My PC keeps displaying the "Do you want to display both secure and nonsecure" content messages when I hit secure sites.

    I tried the standard fix to go into Internet Explorer\Options\Security, but my site has grayed out the Customize button.

    I have launched the Group Policy Editor (gpedit.msc) and believe I need to change the following section:
    User Configuration\Windows Settings\Internet Explorer Maintenance\Security\
    Security Zones and Content Ratings

    From there, the Internet Properties dialog box pops up.  When one selects the Internet icon and clicks on the Custom Level box, there is a Miscellaneous section.  One of the items is called "Display Mixed Content".

    My setting is set to Prompt.  I believe to get rid of the above security warnings, I need to set this to Enable.
    The only issue is that all the options (Disable, Enable, Prompt) are grayed out.

    So, my ultimate question is whether anyone knows of a registry key that controls whether this option is grayed out or not?

    Many thanks in advance.


    jason2074



      Egghead
    • It doesn't matter.
    • Thanked: 200
    • Experience: Beginner
    • OS: Windows XP
    Quote
    My PC keeps displaying the "Do you want to display both secure and nonsecure" content messages when I hit secure sites

    Quote
    In this case, the error message does not indicate a security problem; the error message merely indicates that the page has not loaded all of the secure content fully. This behavior is by design. You cannot disable this error message

    http://support.microsoft.com/kb/184960
     

    Scotty81

      Topic Starter


      Starter

      • Experience: Beginner
      • OS: Unknown
      Jason,

      I realize that there can be some legitimate reasons to post the "Secure and nonsecure message".  I do have a separate issue since a colleague and I have tested the same websites.  My colleague either doesn't get these messages or just gets them once when visiting a site while I get them on EVERy page that I browse to within the site. 

      So, I'm still looking for way to ungray out the options in the Group Policy Editor to restore my desired behavior.

      Scotty81

      jason2074



        Egghead
      • It doesn't matter.
      • Thanked: 200
      • Experience: Beginner
      • OS: Windows XP
      The only time I have seen those secure, nonsecure messages was on a previous or earlier version of IE. Using IE8 has not produced any kind of messages so far. Are you using IE8? Can you post the site just to be sure? There might just be some settings needed to adjust under internet options... Like changing the level of privacy or using the default under your security tab for Internet/Intranet/Trusted Sites/Restricted(default is high and greyed out). Highlighting Internet under security tab and clicking default level will show 3 levels and so to Intranet, Trusted Sites. http://support.microsoft.com/kb/815141
       

      Spoiler



        Specialist

        Thanked: 46
        • Experience: Beginner
        • OS: Windows XP
        Have you tried to reset IE's settings back to the defualt?

        open the internet options and click far right tab and at the bottom you should be able to click on the reset button.


        Whenever I watch TV and I see those poor starving kids all over the world, I can't help but cry. I mean I would love to be skinny like that, but not with all those flies and death and stuff." - Mariah Carey, Pop Singer

        Scotty81

          Topic Starter


          Starter

          • Experience: Beginner
          • OS: Unknown
          Spoiler,

          I hadn't actually tried it, but I just looked at it.  The message said that it would change IE to default settings, except that it stated that it would not change any Group Policy Settings.  Since what I'm trying to do is change a group policy setting, I don't believe that would work.  However, i will try it and then reboot later today.

          I'll let you know what happens.

          Scotty81

          Scotty81

            Topic Starter


            Starter

            • Experience: Beginner
            • OS: Unknown
            Spoiler,

            Your fix worked!  I thought I would have to reboot, but I only had to restart IE.  I had to restore Google Toolbar and a few other things, but that was a small price to pay to fix this issue.  Now, when I explore various links within a secure site, I do not get repeatedly prompted with the "Nonsecure" message. 

            I'm not sure what registry setting changes it made, but I'm glad it worked.

            Thanks again!

            Scotty81

            Spoiler



              Specialist

              Thanked: 46
              • Experience: Beginner
              • OS: Windows XP
              Glad it helped you.

              And welcome to Computer Hope!

              Whenever I watch TV and I see those poor starving kids all over the world, I can't help but cry. I mean I would love to be skinny like that, but not with all those flies and death and stuff." - Mariah Carey, Pop Singer