Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: Changing the language on windows 7  (Read 2260 times)

0 Members and 1 Guest are viewing this topic.


    Topic Starter


    • Experience: Beginner
    • OS: Unknown
    Changing the language on windows 7
    « on: September 18, 2011, 04:35:30 AM »
    Is it possible to change the language on windows 7.
    if possible I need some guide lines.
    I want to change from English to French

    Salmon Trout

    • Guest
    Re: Changing the language on windows 7
    « Reply #1 on: September 18, 2011, 04:37:50 AM »
    What is the source of this Windows 7 installation?



      Thanked: 3
      • Experience: Beginner
      • OS: Windows XP
      Re: Changing the language on windows 7
      « Reply #2 on: September 19, 2011, 07:40:04 AM »
      The Language Packs are only supported in Windows 7 Ultimate and Windows 7 Enterprise.  They will be listed in the Windows Update screen.  If you do not have Windows 7 Ultimate you can't use the Language packs.

      You may follow this procedure to download and install a Windows 7 language pack:

      1.    Start Microsoft Update. To do this, click Start, type Microsoft Update in the Start Search box, and then click Microsoft Update in the Programs list.Collapse this imageExpand th

            2.    Click the optional update links for the language packs.

            3.    Under the Windows 7 Language Packs category, select the desired language pack.

      Note If you install many additional language packs, the disk space and system performance are affected. In particular, disk space and system performance are affected during servicing operations, such as Service Pack installations. Therefore, we recommend that you only add a language pack to your computer if you will use the language pack.

            4.    Click OK, and then click Install updates to start the download and installation process.

             For more information on how to install language pack, please refer to the article below:


            If this doesn’t helps, then you may follow the steps below to fix this issue:

            You should install a Chinese IME before typing Chinese characters. To do this, please follow the steps bellow.

            1)    Click on start > Control Panel

            2)    Click on clock, Language and Region >  Region and Language->

            3)    Keyboard and Languages >Change keyboards > Add > Chinese (Simlified,PRC)

                   Please choose which IME you want to install, and then apply the settings.


      Hope this information is helpful.

      Let me know if this worked.