Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: I'm admin, but I don't have permission to do anything?  (Read 71080 times)

0 Members and 1 Guest are viewing this topic.


    Topic Starter


    • Experience: Beginner
    • OS: Unknown
    I'm admin, but I don't have permission to do anything?
    « on: November 07, 2017, 08:14:21 AM »
    So, a week ago I noticed that my laptop was infested with Trojan virus thing, I'm not even sure if it was a real virus or not, but anyways, I decided to reset the pc to factory setting since I'm paranoid and I know little to nothing about how to deal with viruses and those stuff, and it won't hurt to refresh the laptop once, right? So all was good for a week, laptop was so much slower but I didn't really mind, but then two days ago it started to get all weird. I can't install, uninstall or access some stuff in control panel without the administrator's permission. The weird thing though, is that I'M the administrator, and there is no other user in this laptop. So how am I supposed to give permission to myself?

    Another thing that might be noted, I installed uTorrent from a random website before this started, while installing, I kept clicking Next without reading the content (silly thing to do, I know). Then I noticed that it installed with it Avast Free Antivirus and Web Companion. I have no idea if they're the cause of this or not, since I read somewhere that the antivirus can sometimes take admin privileges or something? I don't know. But anyways, I tried to copy a guide somewhere to allow me admin privileges again, but I don't have access to open windows firewall. Then I tried to uninstall them, but again, I have no access. I tried to make myself admin through the cmd by writing "net user administrator /active:yes" but I got "Access denied."

    I have looked up solutions for this, but nothing seems to be working. I've tried the "right click folder > Properties > Security, then add your account" but it showed that my account already had access to it?  ??? ??? I've also tried to uninstall from regedit, but it won't even let me open the regedit thing since I don't have permission to access it.

    I figured that my last choice was to reset the laptop once more, but as I tried to do so, it said "There was a problem resetting your PC. No changes were made"

    I literally can't do anything in this laptop other than browsing the net, I'm denied access to everything else and it's driving me crazy! I've been trying to look up solutions for the past two days and absolutely nothing works. I would really appreciate it if someone could help me with this. I know that it's obvious from the way I'm trying to convey the problem, but I have NO idea how to deal with computers, and I don't speak computer language either, so I'm sorry if I missed some critical information that I should say.

    I don't know if those are important but I'll include them just in case:
    - After this started, the Start menu sometimes would ignore me when I try to click it and I have to wait for a while till I try again. I can open browser and some random folders, so it's not like the laptop was freezing or anything
    -It literally takes a whole minute or more of it ignoring me before showing the "You don't have the permission to access this item" when I try to install or uninstall, or even open some stuff.

    Also, I'm sorry if I put this in the wrong section! wasn't sure which one would be more appropriate.


    • Malware Removal Specialist

    • Genius
    • Thanked: 1020
    • Certifications: List
    • Experience: Expert
    • OS: Windows 10
    Re: I'm admin, but I don't have permission to do anything?
    « Reply #1 on: November 08, 2017, 10:11:54 AM »
    Hello and welcome to Computer Hope Forum. My name is Dave. I will be helping you out with your particular problem on your computer.

    1. I will be working on your Malware issues. This may or may not solve other issues you have with your machine.
    2. The fixes are specific to your problem and should only be used for this issue on this machine.
    3. If you don't know or understand something, please don't hesitate to ask.
    4. Please DO NOT run any other tools or scans while I am helping you.
    5. It is important that you reply to this thread. Do not start a new topic.
    6. Your security programs may give warnings for some of the tools I will ask you to use. Be assured, any links I give are safe.
    7. Absence of symptoms does not mean that everything is clear.

    If you can't access the internet with your infected computer you will have to download and transfer any programs to the computer you're using now and transfer them to the infected computer with a CD-RW or a USB storage device. I prefer a CD because a storage device can get infected. If you use a storage device hold the shift key down while inserting the USB storage device for about 10 secs. You will also have to transfer the logs you receive back to the good computer using the same method until we can get the computer back on-line.
    Please download AdwareCleaner onto your Desktop. AdwCleaner

    Before starting AdwCleaner, close all open programs and internet browsers, then double-click on the AdwCleaner icon.

    If Windows prompts you as to whether or not you wish to run AdwCleaner, please allow it to run.
    When the AdwCleaner program will open, click on the Scan button as shown below.

    AdwCleaner will now start to search for malicious files that may be installed on your computer.
    To remove the files that were detected in the previous step, please click on the Clean button.

    AdwCleaner will now prompt you to save any open files or data as the program will need to reboot the computer. Please do so and then click on the OK button. AdwCleaner will now delete all detected adware from your computer. When it is done it will display an alert that explains what PUPs (Potentially Unwanted Programs) and Adware are. Please read through this information and then press the OK button. You will now be presented with an alert that states AdwCleaner needs to reboot your computer.
    Please click on the OK button to allow AdwCleaner reboot your computer.A log will be produced. Please copy and paste this log in your next reply.
    Please download Malwarebytes Anti-Malware from here.
    Double Click mbam-setup.exe to install the application.
    • It should update automatically if the computer is connected to the internet.
    • Click on Threat Scan and click on Scan Now.
    • The scan may take some time to finish,so please be patient.
    • When the scan is complete make sure all the infections have "quarantine" selected in the Action box.
    • Click on "Apply actions" You may be asked to Restart your computer to completely remove the infections.
    • When disinfection is completed you can click on "Copy to Clipboard".
    • Paste the log in you next reply (CTRL+ V)
    Please download Junkware Removal Tool to your desktop.

    Warning! Once the scan is complete JRT will shut down your browser with NO warning.

    Shut down your protection software now to avoid potential conflicts.

    •Temporarily disable your Antivirus and any Antispyware real time protection before performing a scan. Click this link to see a list of security programs that should be disabled and how to disable them.

    •Run the tool by double-clicking it. If you are using Windows Vista or Windows 7, right-click JRT and select Run as Administrator

    •The tool will open and start scanning your system.

    •Please be patient as this can take a while to complete depending on your system's specifications.

    •On completion, a log (JRT.txt) is saved to your desktop and will automatically open.

    •Copy and Paste the JRT.txt log into your next message.
    Download Security Check by screen317 from the following link and save it to your desktop.

    Security Check

    * Double-click Security Check.bat
    * Follow the on-screen instructions inside of the black box.
    * A Notepad document should open automatically called checkup.txt
    * Post the contents of that document in your next reply.

    Note: If a security program requests permission from dig.exe to access the Internet, allow it to do so.
    Windows 8 and Windows 10 dual boot with two SSD's


      Topic Starter


      • Experience: Beginner
      • OS: Unknown
      Re: I'm admin, but I don't have permission to do anything?
      « Reply #2 on: November 08, 2017, 10:33:16 AM »
      Hello, Dave!

      I appreciate you taking the time into trying to help me with this. However, the problem is that it won't let me install anything at all. I can download anything just fine, but when I try to open it, it shows me the following message: "Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item." This happens to literally everything that I try to open or install, even to the AdwCleaner and the rest of the things that you suggested.

      I'm sorry that after all the effort you put into replying I couldn't even do the first step.  :( I really have no idea what's causing this problem.


      • Malware Removal Specialist

      • Genius
      • Thanked: 1020
      • Certifications: List
      • Experience: Expert
      • OS: Windows 10
      Re: I'm admin, but I don't have permission to do anything?
      « Reply #3 on: November 10, 2017, 10:07:49 AM »
      Please try running them in Safe Mode.
      You can also try the method described here.
      Windows 8 and Windows 10 dual boot with two SSD's