Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: Autoplay Doesn't Work  (Read 19481 times)

0 Members and 1 Guest are viewing this topic.

Hopester Doofus

    Topic Starter


    Adviser

  • Hope-ing To Help
  • Thanked: 3
    Autoplay Doesn't Work
    « on: January 02, 2006, 12:45:04 PM »
    Problem:
    When I insert a CD or DVD in my drive, it doesn't Autoplay.

    Possible Related Problem:

    When I go into My Computer, the disk that is shown in the drive is the disk that was in there previously. When I click Explore it lists the files on the disk that was in there previously, rather than the new one I've just inserted. If I leave the disk in and reboot, the new disk appears. This happens with ALL disks.


    Solutions:

    (These appear here in no particular recommended order)


    Install Service Pack 2 if you have not already done so. Microsoft acknowledges a known issue with Service Pack 1 and this particular problem, and recommends that Service Pack 2 be installed as a possible fix. (XP users only)


    Remove the drives from your Device Manager, and reboot. Doing this forces Windows to re-install the drivers for your CD and/or DVD drives. Find your Device Manager (depending on your operating system, there are different ways to do this), select the drive(s) in question and Disable or Uninstall them. Then restart your PC.


    Edit your registry to Enable Auto Insert Notification for CD Drives. Some programs will disable this default setting to play inserted CDs automatically (Roxio applications do this, for example). To re-enable this functionality:

    1.  Navigate to the following Registry key:
         HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

    2.  Double-click Autorun

    3.  Make sure the value is set to "1" under Value Data.

    4.  Navigate to the following registry key:
         HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer.

    5.  Double-click "NoDriveTypeAutoRun"

    6.  Make sure the value is set to "91" under Value Data.

    7.  Close the registry editor

    8.  Restart your computer.


    « Last Edit: March 30, 2007, 03:11:09 AM by Dilbert »
    Thereís no limit to what you can achieve if you donít mind who gets the credit.