Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: IRQ problems? or PCI problems?  (Read 38970 times)

0 Members and 1 Guest are viewing this topic.

comda

    Topic Starter


    Adviser
  • Thanked: 6
    • Yes
  • Experience: Experienced
  • OS: Windows XP
IRQ problems? or PCI problems?
« on: January 08, 2023, 06:51:57 PM »
Hi Guys,

I'm Back. After a GPU failure i rebuild this machine and found a weird phenomenon that i need your help with. The board i am running has a AGP, 5 X PCI slots and 2 ISA slots. Ive found if i have ANYTHING in the PCI slots, my AWE32 Soundblaster doesnt work, or the computer wont boot into windows. it will throw a "windows protection error" or something like that. I'll pull the PCI card out and no error for the AWE32. I was reading something and suggested to look at IRQ and Resource ranges. To be honest ive no clue what that means.

I tried having a VIA USB card in the PCI and a ethernet port. the USB card worked perfectly. i tried fresh installs and using and installing drivers for the sound card besides the windows ones and it will still throw an error 11 "this device has problems and will not start" when i have anything populated in the PCI slots.

I dont need the Ethernet card. That was more to just put in for jokes. But the USB card has been useful. Any ideas?

im running the following

VIA Apollo Spacewalker AV11 Motherboard
1ghz Coppermine CPU
Ati Radeon 9700 Pro 128mb GPU
512mb ram.
Awe32 Soundblaster ISA audio card

Thank you.

BC_Programmer


    Mastermind
  • Typing is no substitute for thinking.
  • Thanked: 1140
    • Yes
    • Yes
    • BC-Programming.com
  • Certifications: List
  • Computer: Specs
  • Experience: Beginner
  • OS: Windows 11
Re: IRQ problems? or PCI problems?
« Reply #1 on: January 09, 2023, 01:55:31 PM »
What is the model number of the card? (CT#####)

It's possible the one you have doesn't have ISA PnP capabilities (I can't confirm if all AWE32's were ISA PnP), so resources have to be assigned manually, Or it is PnP, but the BIOS is not configuring the card at boot properly.

If you have the card version that has memory slots on-board, you will need to set a jumper appropriately to match if there is or is not memory or it could cause problems.

Protection Error might not be related. Windows 95 will do that without a patch with CPUs faster than around 400Mhz or so. here is a patch for that. MS had a patch in the 90's too, but I can't find that.

Might not be insensible to confirm the RAM is good. iirc driver allocations usually start at the top of memory, so it could be that with some configurations it goes down into some bad memory space or something.







I was trying to dereference Null Pointers before it was cool.