Welcome guest. Before posting on our computer help forum, you must register. Click here it's easy and free.

Author Topic: XP DNS Cache not working as I thought it should;curiosity question  (Read 5421 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
(Previously posted in Windows forum but now removed after no responses.)

I'm running Windows XP on a Dell Precision 390 and have a local cable TV company (RCN) as my ISP via cable modem.

I was exploring the Windows ipconfig /displaydns command and I noticed that my cache only had two "host" entries in it: one for "localhost" and another for "#.#.#.###.in-addr.arpa".  None of my recent internet site visits were in there.  I expected this cache to be filled with lots of urls so I followed up.  Based on what I found I thought the "time to kill" setting might be set to zero or something like that.

I checked the registry and there was not a MaxCacheTtl item in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNSCache\Parameters.  Thinking that if I added this entry I would start seeing more items in the DNS cache, I added a MaxCacheTtl entry and set the length to one day (in seconds).  I followed the instructions at http://support.microsoft.com/kb/318803.

But the registry change won't take, or some other setting is overriding it.  I expect to see the urls of all the internet sites I'm visiting in the dns cache, but I still only get the host entries described above.

This isn't really a problem.  It's a curiosity question.  Why won't the registry change take?  Is there some other MS control setting that overrides it?  Is it something my ISP is doing? 

Here's one clue, I'd like to follow up on.  The MS link above says

The TTL for positive responses is the lesser of the following values:
  The number of seconds specified in the query response the resolver received
The value of the MaxCacheTtl registry setting.

How can I check "the number of seconds specified in the query response" to see if this is set to 0 or 1 second.

Thanks for any help you can give me to learn about this stuff.


  • Thanked: 1
    Well I'd like to help you out but my XP doesn't appear to be caching DNS lookups either and the only info I'm able to find via search engines is on how to disable the cache. It's very puzzling...
    Any sufficiently advanced technology is indistinguishable from magic.
    Arthur C. Clarke (1917 - 2008)



      Thanked: 50
    • Experience: Beginner
    • OS: Windows XP
    Whenever I watch TV and I see those poor starving kids all over the world, I can't help but cry. I mean I would love to be skinny like that, but not with all those flies and death and stuff." - Mariah Carey, Pop Singer


    • Guest
    Thank you Spoiler.  I'd seen the article by Vic Laurie; the other is new.  They're helpful in general but don't explain why the DNS cache is behaving as advertised.  Based on the second article I'm pretty sure I have the TTL setting in the registry correctly set.  Oh, well.